Search Engine Smackdown requires version 8 of the Flash player or higher to run, you can get the latest version here.